VTiger form for lead generation

S27TOVA4U578

Today I had the problem of having to create a form for leads for my website. Using the native functions of VTiger the form was saved correctly, but the fields were not present. I have installed the version 6.4
Searching the net I found the solution to this link:

In practice operate in this way:

1.

CREATE TABLE `vtiger_webforms_field` ( `id` int(19) NOT NULL AUTO_INCREMENT, `webformid` int(19) NOT NULL, `fieldname` varchar(50) NOT NULL, `neutralizedfield` varchar(50) NOT NULL, `defaultvalue` varchar(200) DEFAULT NULL, `required` int(10) NOT NULL DEFAULT ‘0’, `captcha` int(1) NOT NULL DEFAULT ‘0’, `roundrobin` int(1) NOT NULL DEFAULT ‘0’, `roundrobin_userid` varchar(256) DEFAULT NULL, `roundrobin_logic` int(11) NOT NULL DEFAULT ‘0’, PRIMARY KEY (`id`), KEY `webforms_webforms_field_idx` (`id`), KEY `fk_1_vtiger_webforms_field` (`webformid`), KEY `fk_2_vtiger_webforms_field` (`fieldname`), CONSTRAINT `fk_1_vtiger_webforms_field` FOREIGN KEY (`webformid`) REFERENCES `vtiger_webforms` (`id`) ON DELETE CASCADE, CONSTRAINT `fk_3_vtiger_webforms_field` FOREIGN KEY (`fieldname`) REFERENCES `vtiger_field` (`fieldname`) ON DELETE CASCADE )

2.

ALTER TABLE `vtiger_webforms_field` ADD `sequence` INT NULL DEFAULT NULL AFTER `required` , ADD `hidden` INT NULL DEFAULT NULL AFTER `sequence`

CAUTION:
to me it worked but before I made a backup of the database

This information DATES ARE WITHOUT ANY WARRANTY OF SAFETY AND IF THEY WORK ON OTHER VERSIONS VTiger

Advertisements
This entry was posted in Uncategorized. Bookmark the permalink.

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s